Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 09, 2026 - 03:00 EDT
Scheduled
The pharmacist and patient booking experience will be temporarily unavailable during the upcoming maintenance window as the team upgrades the database servers
Posted Aug 28, 2026 - 16:33 EDT
This scheduled maintenance affected: Pharmacist Platform (Dashboard, Patient List + Profile, Calendar) and Patient Side (Public Booking Link).